The goal of this release is to improve the code quality. This is a major (and disruptive) update, there are changes in most supervisor codes : scripts need to be updated according to these changes. This is an on-going work in the rc branch of the COMPASS GitLab.
This note will try to summarize all the major changes
PEP 8 naming convention Basicaly, it can be summurised like this:
class name = CamelCase function and variable names = snake_case For example:
class MyBeautifulClass: def my_favorite_function(self, my_variable_with_explicit_name): """ snake_case for functions and variable name Explicit names are required : avoid single letter variable for example """ All names must be explicit, even for temporary variable : avoid single letter variable, acronym, and so on….
It has been already applied to all supervisor classes. For example, applyVoltGetSlopes became apply_volt_and_get_slopes Then, all the function written in camel case has changed, so the scripts which were using it must be adapted also.